Using Library Modules in VHDL Designs
This tutorial explains how Altera’s library modules can be included in VHDL-based designs, which are implemented by using the Quartus R II software.
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Practical designs often include commonly used circuit blocks such as adders, subtractors, multipliers, decoders,
counters, and shifters. Altera provides efficient implementations of such blocks in the form of library modules that
can be instantiated in VHDL designs. The compiler may recognize that a standard function specified in VHDL
code can be realized using a library module, in which case it may automatically infer this module. However, many
library modules provide functionality that is too complex to be recognized automatically by the compiler. These
modules have to be instantiated in the design explicitly by the user.
Quartus R II software includes a library of parameterized modules (LPM). The modules are general in structure and they are tailored to a specific application by specifying the values of general parameters.
Doing this tutorial, the reader will learn about:
• Library of parameterizes modules (LPMs)
• Configuring an LPM for use in a circuit
• Instantiating an LPM in a designed circuit
The detailed examples in the tutorial were obtained using the Quartus II version 5.0, but other versions of the
software can also be used.

1 Example Circuit
As an example, we will use the adder/subtractor circuit shown in Figure 1. It can add, subtract, and accumulate n-bit numbers using the 2’s complement number representation. The two primary inputs are numbers
A = an−1 an−2 · · · a0 and B = bn−1 bn−2 · · · b0 , and the primary output is Z = zn−1 zn−2 · · · z0 . Another input
is the AddSub control signal which causes Z = A + B to be performed when AddSub = 0 and Z = A − B when
AddSub = 1. A second control input, Sel, is used to select the accumulator mode of operation. If Sel = 0, the
operation Z = A ± B is performed, but if Sel = 1, then B is added to or subtracted from the current value of Z.
If the addition or subtraction operations result in arithmetic overflow, an output signal, Overflow, is asserted.
To make it easier to deal with asynchronous input signals, they are loaded into flip-flops on a positive edge of
the clock. Thus, inputs A and B will be loaded into registers Areg and Breg, while Sel and AddSub will be loaded
into flip-flops SelR and AddSubR, respectively. The adder/subtractor circuit places the result into register Zreg.
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Figure 1. The adder/subtractor circuit.

The required circuit is described by the VHDL code in Figure 2. For our example, we use a 16-bit circuit as
specified by n = 16. Implement this circuit as follows:
• Create a project addersubtractor.
• Include a file addersubtractor.vhd, which corresponds to Figure 2, in the project. For convenience, this file
is provided in the directory DE2 tutorials\design files, which is included on the CD-ROM that accompanies
the DE2 board and can also be found on Altera’s DE2 web pages.
• Choose the Cyclone II EP2C35F672C6 device, which is the FPGA chip on Altera’s DE2 board.
• Compile the design.
• Simulate the design by applying some typical inputs.
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LIBRARY ieee ;
USE ieee.std logic 1164.all ;
−− Top-level entity
ENTITY addersubtractor IS
GENERIC ( n : INTEGER := 16 ) ;
PORT (A, B
:
Clock, Reset, Sel, AddSub :
Z
:
Overflow
:
END addersubtractor ;

IN STD LOGIC VECTOR(n−1 DOWNTO 0) ;
IN STD LOGIC ;
BUFFER STD LOGIC VECTOR(n−1 DOWNTO 0) ;
OUT STD LOGIC ) ;

ARCHITECTURE Behavior OF addersubtractor IS
SIGNAL G, H, M, Areg, Breg, Zreg, AddSubR n : STD LOGIC VECTOR(n-1 DOWNTO 0) ;
SIGNAL SelR, AddSubR, carryout, over flow : STD LOGIC ;
COMPONENT mux2to1
GENERIC ( k : INTEGER := 8 ) ;
PORT ( V, W : IN STD LOGIC VECTOR(k-1 DOWNTO 0) ;
Selm : IN STD LOGIC ;
F
: OUT STD LOGIC VECTOR(k-1 DOWNTO 0) ) ;
END COMPONENT ;
COMPONENT adderk
GENERIC ( k : INTEGER := 8 ) ;
PORT (carryin : IN STD LOGIC ;
X, Y
: IN STD LOGIC VECTOR(k-1 DOWNTO 0) ;
S
: OUT STD LOGIC VECTOR(k-1 DOWNTO 0) ;
carryout : OUT STD LOGIC ) ;
END COMPONENT ;
BEGIN
PROCESS ( Reset, Clock )
BEGIN
IF Reset = ’1’ THEN
Areg <= (OTHERS => ’0’); Breg <= (OTHERS => ’0’);
Zreg <= (OTHERS => ’0’); SelR <= ’0’; AddSubR <= ’0’; Overflow <= ’0’;
ELSIF Clock’EVENT AND Clock = ’1’ THEN
Areg <= A; Breg <= B; Zreg <= M;
SelR <= Sel; AddSubR <= AddSub; Overflow <= over flow;
END IF ;
END PROCESS ;
nbit adder: adderk
GENERIC MAP ( k => n )
PORT MAP ( AddSubR, G, H, M, carryout ) ;
multiplexer: mux2to1
GENERIC MAP ( k => n )
PORT MAP ( Areg, Z, SelR, G ) ;
AddSubR n <= (OTHERS => AddSubR) ;
H <= Breg XOR AddSubR n ;
over flow <= carryout XOR G(n−1) XOR H(n−1) XOR M(n−1) ;
Z <= Zreg ;
END Behavior;
. . . continued in Part b
Figure 2. VHDL code for the circuit in Figure 1 (Part a).
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−− k-bit 2-to-1 multiplexer
LIBRARY ieee ;
USE ieee.std logic 1164.all ;
ENTITY mux2to1
GENERIC ( k
PORT ( V, W
Selm
F
END mux2to1 ;

IS
: INTEGER := 8 ) ;
: IN STD LOGIC VECTOR(k−1 DOWNTO 0) ;
: IN STD LOGIC ;
: OUT STD LOGIC VECTOR(k−1 DOWNTO 0) ) ;

ARCHITECTURE Behavior OF mux2to1 IS
BEGIN
PROCESS ( V, W, Selm )
BEGIN
IF Selm = ’0’ THEN
F <= V ;
ELSE
F <= W ;
END IF ;
END PROCESS ;
END Behavior ;
−− k-bit adder
LIBRARY ieee ;
USE ieee.std logic 1164.all ;
USE ieee.std logic signed.all ;
ENTITY adderk IS
GENERIC ( k : INTEGER := 8 ) ;
PORT ( carryin : IN STD LOGIC ;
X, Y
: IN STD LOGIC VECTOR(k−1 DOWNTO 0) ;
S
: OUT STD LOGIC VECTOR(k−1 DOWNTO 0) ;
carryout : OUT STD LOGIC ) ;
END adderk ;
ARCHITECTURE Behavior OF adderk IS
SIGNAL Sum : STD LOGIC VECTOR(k DOWNTO 0) ;
BEGIN
Sum <= (’0’ & X) + (’0’ & Y) + carryin ;
S <= Sum(k−1 DOWNTO 0) ;
carryout <= Sum(k) ;
END Behavior ;
Figure 2. VHDL code for the circuit in Figure 1 (Part b).
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2 Library of Parameterized Modules
The LPMs in the library of parameterized modules are general in structure and they can be configured to suit a
specific application by specifying the values of various parameters. Select Help > Megafunctions/LPM to see a
listing of the available LPMs. One of them is an adder/subtractor module called lpm add sub megafunction. Select
this module to see its description. The module has a number of inputs and outputs, some of which may be omitted
in a given application. Several parameters can be defined to specify a particular mode of operation. For example,
the number of bits in the operands is specified in the parameter LPM WIDTH. The LPM REPRESENTATION
parameter specifies whether the operands are to be interpreted as signed or unsigned numbers, and so on. Templates on how an LPM can be instantiated in a hardware description language are given in the description of the
module. Using these templates is somewhat cumbersome, so Quartus II software provides a wizard that makes the
instantiation of LPMs easy.
We will use the lpm add sub module to simplify our adder/subtractor circuit defined in Figures 1 and 2. The
augmented circuit is given in Figure 3. The lpm add sub module, instantiated under the name megaddsub, replaces
the adder circuit as well as the XOR gates that provide the input H to the adder. Since arithmetic overflow is one
of the outputs that the LPM provides, it is not necessary to generate this output with a separate XOR gate.
To implement this adder/subtractor circuit, create a new directory named tutorial lpm, and then create a project
addersubtractor2. Choose the same Cyclone II EP2C35F672C6 device, to allow a direct comparison of implemented designs.
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Figure 3. The augmented adder/subtractor circuit.
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The new design will include the desired LPM subcircuit specified as a VHDL component that will be instantiated in the top-level VHDL design entity. The VHDL component for the LPM subcircuit is generated by using a
wizard as follows:
1. Select Tools > MegaWizard Plug-in Manager, which leads to a sequence of seven pop-up boxes in which
the user can specify the details of the desired LPM.
2. In the box shown in Figure 4 indicate Create a new custom megafunction variation and click Next.

Figure 4. Choose to define an LPM.

Figure 5. Choose an LPM from the available library.

3. The box in Figure 5 provides a list of the available LPMs. Expand the “arithmetic” sublist and select
LPM ADD SUB. Choose VHDL as the type of output file that should be created. The output file must be
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given a name; choose the name megaddsub.vhd and indicate that the file should be placed in the directory
tutorial lpm as shown in the figure. Press Next.
4. In the box in Figure 6 specify that the width of the data inputs is 16 bits. Also, specify the operating mode
in which one of the ports allows performing both addition and subtraction of the input operand, under the
control of the add sub input. A symbol for the resulting LPM is shown in the top left corner. Note that if
add sub = 1 then result = A + B; otherwise, result = A − B. This interpretation of the control input and the
operation performed is different from our original design in Figures 1 and 2, which we have to account for
in the modified design. Observe that we have included this change in the circuit in Figure 3. Click Next.

Figure 6. Specify the size of data inputs.

5. In the box in Figure 7, specify that the values of both inputs may vary and click Next.

Figure 7. Further specification of inputs.

6. The box in Figure 8 allows the designer to indicate optional inputs and outputs that may be specified. Since
we need the overflow signal, make the Create an overflow output choice and press Next.
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Figure 8. Specify the Overflow output.

7. In the box in Figure 9 say No to the pipelining option and click Next.

Figure 9. Refuse the pipelining option.

8. Figure 10 gives a summary which shows the files that the wizard will create. Press Finish to complete the
process.

Figure 10. Files created by the wizard.
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3 Augmented Circuit with an LPM
We will use the file megaddsub.vhd in our modified design. Figure 11 depicts the VHDL code in this file; note that
we have not shown the comments in order to keep the figure small.
// Adder/subtractor module created by the MegaWizard
LIBRARY ieee;
USE ieee.std logic 1164.all;
LIBRARY lpm;
USE lpm.lpm components.all;
ENTITY megaddsub IS
PORT ( add sub :
dataa
:
datab
:
result
:
overflow :
END megaddsub;
ARCHITECTURE SYN
SIGNAL sub wire0
SIGNAL sub wire1

IN STD LOGIC ;
IN STD LOGIC VECTOR (15 DOWNTO 0);
IN STD LOGIC VECTOR (15 DOWNTO 0);
OUT STD LOGIC VECTOR (15 DOWNTO 0);
OUT STD LOGIC );
OF megaddsub IS
: STD LOGIC ;
: STD LOGIC VECTOR (15 DOWNTO 0);

COMPONENT lpm add sub
GENERIC ( lpm width : NATURAL;
lpm direction : STRING;
lpm type : STRING;
lpm hint : STRING );
PORT ( dataa
: IN STD LOGIC VECTOR (15 DOWNTO 0);
add sub : IN STD LOGIC ;
datab
: IN STD LOGIC VECTOR (15 DOWNTO 0);
overflow : OUT STD LOGIC ;
result
: OUT STD LOGIC VECTOR (15 DOWNTO 0) );
END COMPONENT;
BEGIN
overflow <= sub wire0;
result <= sub wire1(15 DOWNTO 0);
lpm add sub component : lpm add sub
GENERIC MAP ( lpm width => 16,
lpm direction => ”UNUSED”,
lpm type => ”LPM ADD SUB”,
lpm hint => ”ONE INPUT IS CONSTANT=NO,CIN USED=NO” )
PORT MAP ( dataa => dataa,
add sub => add sub,
datab => datab,
overflow => sub wire0,
result => sub wire1 );
END SYN;
Figure 11. VHDL code for the ADD SUB LPM.
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The modified VHDL code for the adder/subtractor design is given in Figure 12. It incorporates the code in Figure
11 as a component. Put the code in Figure 12 into a file tutorial lpm\addersubtractor2.vhd. For convenience, the
required file addersubtractor2.vhd is provided in the directory DE2 tutorials\design files, which is included on
the CD-ROM that accompanies the DE2 board and can also be found on Altera’s DE2 web pages.

LIBRARY ieee ;
USE ieee.std logic 1164.all ;
−− Top-level entity
ENTITY addersubtractor2 IS
GENERIC ( n : INTEGER := 16 ) ;
PORT (A, B
:
Clock, Reset, Sel, AddSub :
Z
:
Overflow
:
END addersubtractor2 ;

IN STD LOGIC VECTOR(n−1 DOWNTO 0) ;
IN STD LOGIC ;
BUFFER STD LOGIC VECTOR(n−1 DOWNTO 0) ;
OUT STD LOGIC ) ;

ARCHITECTURE Behavior OF addersubtractor2 IS
SIGNAL G, M, Areg, Breg, Zreg, : STD LOGIC VECTOR(n-1 DOWNTO 0) ;
SIGNAL SelR, AddSubR, over flow : STD LOGIC ;
COMPONENT mux2to1
GENERIC ( k : INTEGER := 8 ) ;
PORT ( V, W : IN STD LOGIC VECTOR(k-1 DOWNTO 0) ;
Selm : IN STD LOGIC ;
F
: OUT STD LOGIC VECTOR(k-1 DOWNTO 0) ) ;
END COMPONENT ;
COMPONENT megaddsub
: IN STD LOGIC ;
PORT (add sub
dataa, datab : IN STD LOGIC VECTOR(15 DOWNTO 0) ;
result
: OUT STD LOGIC VECTOR(15 DOWNTO 0) ;
overflow : OUT STD LOGIC ) ;
END COMPONENT ;
BEGIN
−− Define flip-flops and registers
PROCESS ( Reset, Clock )
BEGIN
IF Reset = ’1’ THEN
Areg <= (OTHERS => ’0’); Breg <= (OTHERS => ’0’);
Zreg <= (OTHERS => ’0’); SelR <= ’0’; AddSubR <= ’0’; Overflow <= ’0’;
ELSIF Clock’EVENT AND Clock = ’1’ THEN
Areg <= A; Breg <= B; Zreg <= M;
SelR <= Sel; AddSubR <= AddSub; Overflow <= over flow;
END IF ;
END PROCESS ;
. . . continued in Part b
Figure 12. VHDL code for the circuit in Figure 3 (Part a).
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−− Define combinational circuit
nbit addsub: megaddsub
PORT MAP ( AddSubR, G, Breg, M, over flow ) ;
multiplexer: mux2to1
GENERIC MAP ( k => n )
PORT MAP ( Areg, Z, SelR, G ) ;
Z <= Zreg ;
END Behavior;
−− k-bit 2-to-1 multiplexer
LIBRARY ieee ;
USE ieee.std logic 1164.all ;
ENTITY mux2to1
GENERIC ( k
PORT ( V, W
Selm
F
END mux2to1 ;

IS
: INTEGER := 8 ) ;
: IN STD LOGIC VECTOR(k−1 DOWNTO 0) ;
: IN STD LOGIC ;
: OUT STD LOGIC VECTOR(k−1 DOWNTO 0) ) ;

ARCHITECTURE Behavior OF mux2to1 IS
BEGIN
PROCESS ( V, W, Selm )
BEGIN
IF Selm = ’0’ THEN
F <= V ;
ELSE
F <= W ;
END IF ;
END PROCESS ;
END Behavior ;
−− 16-bit adder/subtractor LPM created by the MegaWizard
LIBRARY ieee;
USE ieee.std logic 1164.all;
LIBRARY lpm;
USE lpm.lpm components.all;
ENTITY megaddsub IS
PORT ( add sub :
dataa
:
datab
:
result
:
overflow :
END megaddsub;
ARCHITECTURE SYN
SIGNAL sub wire0
SIGNAL sub wire1

IN STD LOGIC ;
IN STD LOGIC VECTOR (15 DOWNTO 0);
IN STD LOGIC VECTOR (15 DOWNTO 0);
OUT STD LOGIC VECTOR (15 DOWNTO 0);
OUT STD LOGIC );
OF megaddsub IS
: STD LOGIC ;
: STD LOGIC VECTOR (15 DOWNTO 0);

. . . continued in Part c
Figure 12. VHDL code for the circuit in Figure 3 (Part b).
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COMPONENT lpm add sub
GENERIC ( lpm width : NATURAL;
lpm direction : STRING;
lpm type : STRING;
lpm hint : STRING );
PORT ( dataa
: IN STD LOGIC VECTOR (15 DOWNTO 0);
add sub : IN STD LOGIC ;
datab
: IN STD LOGIC VECTOR (15 DOWNTO 0);
overflow : OUT STD LOGIC ;
result
: OUT STD LOGIC VECTOR (15 DOWNTO 0) );
END COMPONENT;
BEGIN
overflow <= sub wire0;
result <= sub wire1(15 DOWNTO 0);
lpm add sub component : lpm add sub
GENERIC MAP ( lpm width => 16,
lpm direction => ”UNUSED”,
lpm type => ”LPM ADD SUB”,
lpm hint => ”ONE INPUT IS CONSTANT=NO,CIN USED=NO” )
PORT MAP ( dataa => dataa,
add sub => add sub,
datab => datab,
overflow => sub wire0,
result => sub wire1 );
END SYN;

Figure 12. VHDL code for the circuit in Figure 3 (Part c).

The key differences between this code and Figure 2 are:
• The statements that define the over flow signal and the XOR gates (along with the signal H) are no longer
needed.
• The adderk entity, which specifies the adder circuit, is replaced by megaddsub entity. Note that the dataa
and datab inputs shown in Figure 6 are driven by the G and Breg vectors, respectively.
• AddSubR signal is specified to be the inverted version of the AddSub signal to conform with the usage of
this control signal in the LPM.
If you copied the file addersubtractor2.vhd from the qdesigns directory, you have to include this file in the
project. To do so, select Project > Add/Remove Files in Project to reach the window in Figure 13. Browse
for the available files by clicking the button File name: ... to reach the window in Figure 14. Select the file
addersubtractor2.vhd and click Open, which returns to the window in Figure 13. Click Add to include the file
and then click OK. Now, the modified design can be compiled and simulated in the usual way.
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Figure 13. Inclusion of the new file in the project.

Figure 14. Specify the addersubtractor.vhd file.
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4 Results for the Augmented Design
Compile the design and look at the summary, which is depicted in Figure 15. Observe that the modified design is
implemented in 52 logic elements, which is the same as when using the code in Figure 2. In very small circuits,
which is the case with our example, it is unlikely that using LPMs will result in a significant advantage. However,
in more complex designs the advantage of using LPMs is likely to be significant. The reason is that the LPMs
implement the required logic more efficiently than what the compiler can do from simple VHDL code, such as the
code in Figure 2. The user should consider using an LPM whenever a suitable one exists.

Figure 15. Compilation Results for the Augmented Circuit.
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