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Preface

This document was created with the help of Dr. Hamblen and the Altera Corporation.  It is intended to assist Georgia Tech students in understanding the Altera MaxPlus software and board.  

We would like to thank Dr. Hamblen and the Altera Corporation for providing the documentation on programming the Altera board.

If you would like to submit suggestions, please email your comments to mike@insightsystems.com.

Future revisions of this document will be posted to the Insight Systems web site at http://www.insightsystems.com.  

This document is provided free of charge and is not to be sold.

Table of Contents

I. Purpose

II. Altera Software Versions

III. Computer Hardware Requirements

IV. Software Installation

V. General Information

VI. Tutorial

A. Project Creation

B. Compiling

C. Simulating

D. Programming the Board

VII. Appendix A

Purpose

This document will hopefully assist you in using the Altera software and provide you with an introduction to VHD design.  We have created this document to guide you through the development process and to make you aware of some of the problems we encountered while using the Altera software.

In this tutorial we will be using the MIPS project created by Georgia Institute of Technology professor Dr. Hamblen.  It is available for download from his web site (http://www.ece.gatech.edu/users/189/).  The VHD files are included in Appendix A.  This project will use the Altera software to create the project files, compile, simulate, and program the Altera device.

Altera Software Versions

The Altera software is available from the College of Computer Engineering.  Currently, two versions of the software exist.  The student edition is version 7.21 and can be installed and used without a hardware key.  It does, however, require a software key number available via email from the Altera Web site http://www.altera.com.  The easiest way to get this key is to read the “readme” file after installing the software.  The readme file will contain a link to obtain the key.  Upon completing the required fields, the software key will be emailed to you.  We received the software key in as little as 2 minutes, although individual times may vary.  When you receive the key,  it is best to simply highlight, copy, and paste the key into the software to avoid problems with case.

The professional version requires a hardware key from Altera, which plugs into the parallel port of the computer.  When you enter the hardware key into the software, pay close attention to case and differences between the letter “O” and the number “0” as well as the letter “l” and the number “1”.

The student version is essentially the same as the professional version except that it has only a couple of devices.  As long as your project will fit onto the Flex 10K20 device, the student version will work fine for the most part.  It does have some problems that we encountered.  The timing information included in version 7.21 is strictly preliminary. This means that it is possible that simulation results will not match what you get on the board. 

The student version has additional problems during compiles and syntax checking.  If you define an 8-bit signal and accidentally only assign 7 bits to the signal, the software will generate an internal error, which results in the application closing.  It is then necessary to reboot Windows in order to use the software again since the internal error freezes the Windows 95 resources.  An internal error is also generated if the device you are using is not big enough for the design.  Altera states that the internal error is generated due to the lack of a partitioner in the student version.  The partitioner is used to fit the design onto the device.

The version you choose to use is up to you and the availability of the hardware key, although we recommend that you use the student version to get started.  The ideal situation would be to have a hardware key for each person to use.

Altera has a large web site with a great deal of literature to assist you in developing projects with their software.  It is available at http://www.altera.com.  Some of the documents on the site include technical specifications of the Altera software as well as many “how-to” documents.  Altera also has a tutorial for download; however, their tutorial is approximately 150 pages.

Computer Hardware Requirements

The Altera MaxPlusII professional version requires a minimum of 155MB hard disk space.  The MIPS project requires an additional 22MB of disk space when fully compiled.

Although Altera claims that 128MB RAM is necessary, we found that a Pentium 200 with 512kb cache and 64MB RAM worked fairly well, resulting in a total project recompile in less than an hour.  We also used a Pentium 200 with no cache and 88MB RAM and found that less hard disk activity was necessary during compiling.  The available of cache appeared to make a large difference.  In compiling our project the 64MB computer with 512kb cache completed a compile in 45 minutes while the other computer required over an hour to compile.   Although the machines we used had Windows 95, it is possible to use Windows NT; however, Windows NT requires more RAM in order to achieve the same comparable performance.

Even though the computers we used were very well equipped, we do not recommend attempting to perform other tasks while compiling.  The Altera software does allow you to perform other tasks; however, we found that anything more than just editing a text document slowed the compile down to a crawl. 

Installation Instructions

Installation instructions are included in every CD; nevertheless, we have included them here for your convenience.

1. Place the hardware key onto the parallel port if you are installing the professional version.

2. Insert the CD into the drive.  If you are using the professional version, make sure you are using version 8.1 or higher.  (Version 8.0 includes preliminary timing information for the FLEX devices.)

3. Run the install program as follows:

<CD-ROM Drive>:\pc\maxplus2\install 

4. Follow the instructions on the screen for the remaining installation instructions.

Starting MaxPlus for the first time

When you start using the professional version for the first time, it will be necessary to set-up the hardware key and install the appropriate components.  Simply follow the instructions on the screen and type in the long hardware key phrase that comes with each key.  Make sure you use the appropriate character case.  If you have difficulties with the key, make sure you check your use of the letter “O” and the number “0”.

The student version requires a software key available from the Altera web site.  See the “README” file in the student version for more information.

General Information

Menus

While using the software, you should note that the menus vary depending on the current application module that is open.  For example, if the compiler window is current, then the menu at the top will include an Interface Menu.  This menu is not available if any other software module is current.  This does cause some confusion, so it might be well worth the effort in getting acquainted with each module’s set of menus.

Current Project File

It is possible to open multiple VHD text files and various components at one time.  When you want to compile or simulate a project though, make sure you make the file you want to compile or simulate the current project.  You can do this by choosing “File->Project->Set Project to Current File”.  If you are unsure of what the application considers to be the current file, you can look at the top menu bar, which is the application’s main title bar. 

Project Name

After compiling the application, many additional files will be left in the project directory.  Later, opening the VHD text files will for some unknown reason take a long time to open.  If you only wish to compile the object, simply set the project to the file by selecting “File ->Project->Project Name”.  This will set the project to a given file without actually loading the text file into the editor.  This will reduce the time it takes to recompile the VHD file.

Design Doctor

A feature called the “Design Doctor” is available under the compile menu.  This feature will provide analysis of your design to ensure conformance with certain IEEE rules.  When using the FLEX devices, make sure you choose the “FLEX” rule set from the “File->Design Doctor Settings” menu.  While this feature can be very helpful, it can be somewhat frustrating.  We received warnings about some signals; however, we were unable to locate the source of the problems from the doctor’s cryptic naming scheme.  In order to trace the errors down using this naming convention, it will be necessary to search the module’s report file for the number.  For example, if you are looking for signal “14.Q”, you will be able to find it in the top report file as the following:

Node Name is ‘:14’ = “RegWrite_DD”.

It is also important to note that the use of the Design Doctor will greatly increase the time needed to compile your project.  The Doctor does provide some important information about your project; however, due to the compile time overhead, we recommend that you do not use this feature every time.

The design doctor may generate warnings when compiling individual modules; however, these warnings may disappear once the higher modules are compiled.  For example, when compiling our control module, the design doctor warned us that we needed to sync some signals to clock.  What that module didn’t know is that the signals were synced to the clock; they just weren’t synced to the clock in that particular module.  Compiling the top_spim module showed us that these warnings disappeared and we were left without other useful messages.

Smart Recompile

Smart Recompile option is not always so “smart”.  If you read the help file about this option, you will probably think that this looks like a really good idea.  The first time you compile the project using this option additional database entries will be created.  Later compiles then compare the project to the database entries and will compile only the parts needed.  Unfortunately, this process did not always work 100 per cent of the time.  If only the Memory Initialization Files(MIF) changed, the MaxPlus software failed to recognize the change.  Therefore, it informed us that the project did not change and did not recompile the project as expected.  Also, parent modules did not always detect changes to the lower modules.  To some degree the smart recompile did work; however, minor problems with this option lead us to abandon the feature all together during early development.  This option is best used during later stages of development when only minor modifications were necessary. 

Simulation

Be sure to close the waveform window before performing a simulation.  The simulation will go much slower when the waveform editor window is already open due to numerous screen redraws.  If your simulation is plotting a large time frame and has a large number of signals that are being traced, you will want to have a fast video card.

Compilation Report

After compiling the project, a report will be generated.  This report shows important information including compile time, logic cells and memory used.  It also shows pin-out information and warnings.  You will want to pay particular attention to the number of logic cells and memory used.

***** Project compilation was successful

TOP_DLX

** DEVICE SUMMARY **

Chip/                     Input Output Bidir  Memory  Memory          LCs

POF       Device          Pins  Pins   Pins   Bits % Utilized  LCs  % Utilized

top_dlx   EPF10K70RC240-4  13     21     0    14696     79 %    1279     34 %

User Pins:                 13     21     0  

In this example, 34% of the total logic cells in the FLEX 10K70 device are being used, and 79% of the RAM is being utilized.  If you want to know more about each device’s specs, you should consult the Altera web site.

Other information that is very useful includes node name equations and file hierarchy.  The node name equations may be very important later on when analyzing timing problems to ensure that all flip-flops are using the same global line for clock.

Memory

The Altera FLEX device supports both Random Access Memory(RAM) and Read Only Memory(ROM).  The amount of memory available is device specific.  Using memory has its advantages over using gates.  It compiles much faster, allows for a larger number of memory locations, and it can be initialized very easily using MIF files.  The disadvantage is that memory access is slower than using logic gates.  For an example in the use of memory, look in Appendix A at the MIPS dmemory module or the example shown below.  ROM is similar to RAM with the exception that it does not have a write address.

In order to use the memory components, you must add the following library entry to the project at the top of the VHD file.

LIBRARY LPM;

USE lpm.lpm_components.all;

Dmemory usage:

data_memory: lpm_ram_dq

      GENERIC MAP (lpm_widthad => ADDR_WIDTH,

         lpm_outdata => "UNREGISTERED",

         lpm_indata => "UNREGISTERED",

         lpm_address_control => "UNREGISTERED",

         lpm_file => "dmemory.mif",

         lpm_width => DATA_WIDTH)

      PORT MAP (data => wd_bus(0 to 7), 



    address => ra_bus(0 to 7), 



    we => we,



        --inclock => clock,

 



--outclock => outclock,

                q => mem_data(0 to 7));
This example shows a memory component titled “data_memory”.  This module is using asynchronous memory; therefore, the “inclock” and “outclock” are both commented out.  This means that the memory address is written to “mem_data” as soon as the address is defined.

IMPORTANT NOTE: The address must be stable before the write enable (“we”) signal is enabled.  If the address changes while the write enable signal is high, multiple address signals can be changed.  Careful inspection of the waveform simulation will show when the address signal actually stabilizes.  One way to ensure that the address is stable before a write is to delay the write enable signal until the falling edge of the clock; however, you will need to ensure that sufficient time is given to allow the memory to be written(approximately 40-70 ns).

MIF File

The Memory Initialization File (MIF) is used to initialize the memory locations.  The file can be defined using binary, hex, decimal, or octal signals.  The following example defines 256 memory locations of address width 8 bits.  Both the addresses and memory locations are defined as binary signals.  The pattern “00000000 .. 11111111] : 0;” initializes all memory locations to “0” before each individual address is given.  Note that it is not necessary to define every memory location since this instruction sets all addresses to “0”.

Depth = 256;

Width = 8

Address_radix=bin

Data_radix=bin

% Instruction Pattern %

Content

  Begin

   [00000000 .. 11111111] : 0;

    00000001:  00000001; 

    00000010:  01010101;

  End;                                             

Text File Comments

Comments are defined using “—“ (2 hyphens) before any comment.  There is no way to comment a block of code.  Each line must be preceded by the hyphens.  You can also add comments to the end of a command as follows:


we <= “0”;    --This is an example of a comment on a line

Signal Assignments

Signal assignments can be made using any of the following notations under the 1987 syntax:

We <= “0000”;  --binary assignment

We <= to_stdlogicvector(B”0000”);

We <= to_stdlogicvector(X”0”);  --HEX assignment

We preferred the first version since it appears to be the cleanest in most cases.  The 1993 syntax has a slightly different format for using the “TO_STDLOGICVECTOR” function. 

Following next is the tutorial.  Hopefully you will be able to walk through it with these comments in mind and see how this program works.

Tutorial

This tutorial will provide a step through of a project design.  The project being used is the MIPS model designed by Dr. Hamblen, a computer engineering professor at Georgia Institute of Technology.  This tutorial is broken into five parts: Setup, Writing the Program, Compiling, Simulating, and Programming the Altera Chip.

Setup

Step 1.

Install the Program.  There are detailed instructions that accompany the CD, as well as in this tutorial.

Step 2.

Load the program.  The install procedure should have placed an icon to load the program in the start menu.  Click on this icon.

Writing the Program

Step 1.

The next step is to program your design into the editor.  There are multiple editors provided by Altera.  The one we will use is the text editor.  Figure 1 is the opening screen after the program loads its drivers.

Step 2.

Once loaded, Click on “File -> New”.  This will pull the new file box (see Figure 2).  Click on the “text editor” radio button and click on OK.  This will provide a way to create a VHD file as well as many other types of files. 
[image: image1.png]{AX+plus Il Manager - e:\max2work \dlx\mips\top_flex

G TE
MAR+plus'll






Figure 1
Figure 2 

Step 3.

At this point you can start typing in VHDL code.  The text editor (as seen in Figure 3) is color coded, so you can more easily differentiate between comments, functions, and code.  The code provided in Appendix A will be used from this point on, so you can either type the code in as seen in Appendix A, or you can download the version of code from Dr. Hamblen’s Web Page.

Step 4.

While typing in code, it is advisable to check you syntax to make sure that you are using correct coding styles.  This can be accomplished by clicking on File -> Project -> Save & Check.  Altera provides two versions of VHDL coding styles: VHDL87 and VHDL93.  If you are not familiar with the different versions, it is ok.  Just be sure that the project uses one style throughout the entire project.
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Figure 3

Compiling

This tutorial will walk you through the compilation and simulation of one module (control.vhd).  You will be expected to create the additional modules in the same fashion as defined here.  After creating each file, repeat steps 1-6 below for each module, compiling the lower modules first and working up.

Step 1.

From the Max+PlusII menu item, choose “compiler”.  This step opens the compiler window (see Figure 4).
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Figure 4.
Step 2.

If the “control” module is not the current project name, set the current project using “File->Project->Project Name” or “File->Project->Set Project to current file”.  The second version assumes that the control VHD text file is open and is the current window.

Step 3.

From the “Assign->Device” menu, select the device family and chip that you will be using.  Most likely you will be using the “FLEX10K” family.  You will need to select the chip based on the chip on the Altera board.

Step 4.

Selecting the menu option “Interfaces -> VHDL Netlist Reader Settings” will provide a way to change the syntax editor, which will either be 1987 or 1993.  We chose to use 1993.  

Step 5.

Specify compiler options from the “Processing” menu.  Choose the “Timing SNF Extractor” and “Preserve All Node Name Synonyms” options from that menu.  Also make sure the Design Doctor and Smart Recompile options are not checked.  

Step 6.

Click on the “start” button.  Errors will be reported in the messages window.

Simulation

Once you have successfully compiled your module, you can simulate it to verify its correctness.  The module that will be simulated here is “control”.  You will simulate all other modules in the same manner as described here.

Note:

Unfortunately, if you are using a version of Altera earlier than version 8.1, the timing is only preliminary.  This means that it may work in simulation, but will not necessarily work on a programmed chip.

Step 1.


Make “control” the current project by using “File->Project->Name”.

Step 2.

Create a waveform file (.SCF format) by using the “File->New” menu.

Step 3.

Select the waveform editor and make sure SCF is visible in the type box.  A blank waveform editor (see Figure 5) will open.  
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Figure 5.

Step 4.

In order to trace signals, you will have to add each signal to the waveform.  This is done by right-clicking under the “Name:” field and selecting “Enter Nodes From SNF”.  As long as you compiled with the Timing SNF extractor, this will be an option.  Select the nodes you want to view.  The nodes we are going to view include the following: regwrite, regdst, memwrite, memtoreg, memread, branch, alusrc, aluop1, aluop2, and op.

Step 5.

Now, you will need to provide the signals for the input nodes for the module.  In our case, the only input is the Node Op, which is a 6-bit vector field.  We can input various Ops into the waveform editor and calculate some expected results.  

a.) After the input vector is added to the waveform, select the grid size from the “Options->Grid Size” menu.   This example shows a grid size of 100ns.

b.) Select the end time by selecting “File->End Time” and set the value to 1.0us.

c.) Highlight the time slice from 0 to 200ns for the signal OP by left clicking on the waveform and dragging from time 0 to time 200.  

d.) With the section highlighted, right-click the area and select “Overwrite->Group Value”.

e.) Enter the value “000000”.

f.) Now select the time slice from 200ns to 400ns and enter a group value of “100011”

g.) Next select the time slice from 400ns to 600ns and enter a group value of “000100”

h.) Next select the time slice from 600ns to 800ns and enter a group value of “000000”

i.) Next select the time slice from 800ns to 1us and enter a group value of “111111”

These values were used because they produce actual results from the control module.  They represent various control signals.

Step 6.

a.) Once you have completed the waveform, click on “File->Save”.

b.) Save the waveform as “control.scf”. 

c.) Now click on “File -> Project -> Save and Simulate” (or by clicking on the “Max+Plus -> Simulator” option).

d.) At this point a simulator box will appear.  You can then select various options including :

1. Use Device

2. Set-up/Hold

3. Check Output

4. End Time

5. Oscillations

6. Glitches 

e.) Set the end time to 1.0us, and leave the other options unchecked.

f.) Click on the “start” button to begin the simulation.

g.) When the simulation is complete, click on then “open SCF” button.

h.) Examine this waveform to decide if the design will work.  In our case, we can examine the outputs from the control module, and confirm that they are indeed what we expect (see Figure 6).

i.) Repeat these steps in order to determine if all of the components of your design work independently.  Only then should you attempt to simulate any modules higher up in the hierarchy.   

Figure 6.
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Simulation Conclusion

Altera provides a second way to provide trace information using a text file.  We found the graphical simulation file to be the easier of the two.  If you would like more information on how to use a text source file, consult the Altera Help files or Dr. Hamblen’s web site.

No matter how you choose to simulate the project, verify that the control module behaves as expected.  You will need to complete the project by creating each of the various modules.  Compile each of the lower modules, and then compile top_flex.   You are now ready to program the Altera board.

Programming the Altera Board

Step 1.

Once you have successfully simulated the design, you can provide the final test in programming the chip.  This step is theoretically the toughest because there is no built-in way to see if the programmed chip actually works.  In our case, we will be using a computer monitor to check the outcome of the chip.  Dr. Hamblen’s version of the MIPS model has included a top_flex file.  This file provides the chip with a way to display output to a computer monitor.

Step 2.

If you are creating the top_flex module instead of using the downloaded version from Dr. Hamblen’s web site, it will be necessary to modify the ACF file for the TOP_FLEX module.  This file will associate the device pin-outs with the board’s devices.  You will need the section that assigns the input and output pins to a number.

Step 3.
Make “top_flex.vhd” the current project using “File -> Project  -> Name”.  “Top_flex.acf” must be in the project directory since it contains the FLEX chip pin assignment information. 

Step 4.

Select “MaxPlus -> Programmer”.  Using the JTAG menu, check to see that Multi-Device is turned on.  In “JTAG-> multi device JTAG chain setup”, select EPF10K20 as the device and “top_flex.sof as the programming file to download.  In case of problems, see UP1 board manual pages 20-22 for more details. A copy is included on the following page.  Under options -> hardware select byteblaster and lpt2. Note: Jumpers must be set for flex only on UP1 board, power supply must be connected, and cable must be plugged into printer port.  When everything is setup, the configure button in the programming window should highlight.  To download the board click on the highlighted configure button.  

The MIPS computer will display information on the VGA monitor after downloading is complete.  Flex PB1 is the clock step and Flex PB2 is reset (note: these are the pushbuttons to the right and top of the board as seen in figure 7).  The LEDs will display the program counter (PC).

Detailed Information Needed only to Download and Run the Design on the CPLD on the Altera UP1 Board
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              Figure 7.  Altera UP1 CLPD Demo Board
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Appendix A

--

--

-- control module (simulates SPIM control module)

--

-- Copyright (c) 1996 J. Hamblen, Georgia Tech, School of ECE, Atlanta, GA

--

library IEEE;

use  IEEE.STD_LOGIC_1164.all;

use  IEEE.STD_LOGIC_ARITH.all;

use IEEE.STD_LOGIC_SIGNED.all;

LIBRARY lpm;

USE lpm.lpm_components.ALL;

entity control is

   port( signal Op : in std_logic_vector(5 downto 0);

                signal RegDst : out std_logic;

                signal ALUSrc : out std_logic;

                signal MemtoReg : out std_logic;

                signal RegWrite : out std_logic;

                signal MemRead : out std_logic;

                signal MemWrite : out std_logic;

                signal Branch : out std_logic;

                signal ALUop0 : out std_logic;

                signal ALUop1 : out std_logic;

                signal clock: in std_logic);

end control;

--

-- SPIM control architecture

--

architecture behavior of control is

        Component LCELL

          Port (a_in: in std_logic; 

                a_out: out std_logic);

        End Component;

   signal  Rformat, Lw, Sw, Beq : std_logic;

   signal  Op_out: std_logic_vector(5 Downto 0);

begin           -- behavior of SPIM control

------------------------------------------------------------------------------

-- Patch to isolate logic and help in logic synthesis step

Op_Buf0: LCELL

         Port map (a_in => Op(0), a_out => Op_out(0));

Op_Buf1: LCELL

         Port map (a_in => Op(1), a_out => Op_out(1));

Op_Buf2: LCELL

         Port map (a_in => Op(2), a_out => Op_out(2));

Op_Buf3: LCELL

         Port map (a_in => Op(3), a_out => Op_out(3));

Op_Buf4: LCELL

         Port map (a_in => Op(4), a_out => Op_out(4));

Op_Buf5: LCELL

         Port map (a_in => Op(5), a_out => Op_out(5));

-- Normal Code

                Rformat <= '1' When Op_out = "000000" Else '0';

                Lw      <= '1' When Op_out = "100011" Else '0';

                Sw      <= '1' When Op_out = "101011" Else '0';

                Beq     <= '1' When Op_out = "000100" Else '0';

                RegDst <=  Rformat;

                ALUSrc <=  Lw or Sw;

                MemtoReg <=  Lw;

                RegWrite <=  Rformat or Lw;

                MemRead <=  Lw;

                MemWrite <=  Sw; 

                Branch <=  Beq;

                ALUOp1 <=  Rformat;

                ALUOp0 <=  Beq; 

end behavior;

--


--


-- DMEMORY module (provides the data memory for the SPIM computer)


-- Only 2 locations implemented - Addresses 0 and 1 are read/write

-- Locations set to initial values, imemx, on reset

--

--

library IEEE;

use IEEE.STD_LOGIC_1164.all;

use IEEE.STD_LOGIC_ARITH.all;

use IEEE.STD_LOGIC_SIGNED.all;

entity dmemory is

   port(rd_bus : out std_logic_vector(7 downto 0);

        ra_bus : in std_logic_vector(7 downto 0);

        wd_bus : in std_logic_vector(7 downto 0);

        wadd_bus : in std_logic_vector(7 downto 0);

        MemRead, Memwrite, MemtoReg : in std_logic;

                clock,reset: in std_logic);

end dmemory;

--

-- DMEMORY architecture

--

architecture behavior of dmemory is

  signal mem0,mem1 : std_logic_vector(7 downto 0);

  signal muxout,muxmem0,muxmem1,imem0,imem1 : std_logic_vector(7 downto 0);

  signal mem0write, mem1write : std_logic;

  signal address : std_logic_vector(2 downto 0);

begin

-- Read Data Memory

address <= ra_bus(2 downto 0);

muxout <= mem0 WHEN address=TO_STDLOGICVECTOR(B"000") ELSE

          mem1 WHEN address=TO_STDLOGICVECTOR(B"001") ELSE 

          To_stdlogicvector(X"FF");

-- Mux to skip data memory for Rformat instructions

rd_bus <= ra_bus(7 downto 0) WHEN (MemtoReg='0') ELSE muxout WHEN (MemRead='1')

                ELSE CONV_STD_LOGIC_VECTOR(255,8);

-- Write to data memory?

mem0write <= '1' When ((Memwrite='1') AND(wadd_bus(2 downto 0)="000"))

              ELSE '0';

mem1write <= '1' When ((Memwrite='1') AND (wadd_bus(2 downto 0)="001"))

              ELSE '0';

imem0 <= To_stdlogicvector(X"55");

imem1 <= To_stdlogicvector(X"AA");

muxmem0 <= wd_bus WHEN mem0write='1' ELSE mem0;

muxmem1 <= wd_bus WHEN mem1write='1' ELSE mem1;

Process

 Begin   

 Wait until clock'event and clock='1';

   if (reset = '1') then

     mem0 <= imem0;

     mem1 <= imem1;

   else

     mem0 <= muxmem0;

     mem1 <= muxmem1;

   end if;

 end process;

end behavior;

--


--


-- Execute module (simulates SPIM (ALU) Execute module)


--


--Copyright (c) 1996 J. Hamblen, Georgia Tech, School of ECE,Atlanta,GA


--


--


library IEEE;


use IEEE.STD_LOGIC_1164.all;

use IEEE.STD_LOGIC_ARITH.all;

use IEEE.STD_LOGIC_SIGNED.all;

entity  Execute is

        port(Readdata1 : in std_logic_vector(7 downto 0);

Readdata2 : in std_logic_vector(7 downto 0);

Extend : in std_logic_vector(7 downto 0);

Func_op : in std_logic_vector(5 downto 0);

ALUOp0 : in std_logic;

ALUOp1 : in std_logic; 

ALUSrc : in std_logic;

Zero : out std_logic;

ALUResult : out std_logic_vector(7 downto 0);

ADDResult : out std_logic_vector(7 downto 0);

PCadd : in std_logic_vector(7 downto 0);

clock: in std_logic);

end Execute;

architecture behavior of Execute is

Signal Ainput, Binput : std_logic_vector(7 downto 0);

Signal ResMux: std_logic_vector(7 downto 0);

Signal BAddout : std_logic_vector(8 downto 0);

Signal ALUctl: std_logic_vector(2 downto 0);


begin


 Ainput <= Readdata1;

         Binput <= Readdata2 WHEN (ALUSrc='0') ELSE Extend(7 downto 0);

         ALUctl(0) <= (Func_op(0) OR Func_op(3)) AND ALUOp1;

         ALUctl(1) <= (NOT Func_op(2)) OR (NOT ALUOp1);

         ALUctl(2) <= (Func_op(1) AND ALUOp1) OR ALUOp0;

-- Generate Zero Flag

    Zero <= '1' WHEN (ResMux(7 downto 0) = To_stdlogicvector(X"00")) ELSE '0';    

-- Select ALU output        

    ALUresult <= To_stdlogicvector(B"0000000") & Resmux(7) WHEN ALUctl="111" 

    ELSE ResMux(7 downto 0);

-- Adder for Branch Address

        BAddout<=PCadd + (Extend(6 downto 0) & '0' & '0');

        ADDresult <= BAddout(7 downto 0);        

Process (ALUctl,Ainput,Binput)

begin

 case ALUctl(2 downto 0) is

 -- Select ALU operation

 -- ALU performs ALUresult = bus_A AND bus_B

 WHEN "000" => ResMux <= Ainput AND Binput; 

 -- ALU performs ALUresult = bus_A OR bus_B

 WHEN "001" => ResMux <= Ainput OR Binput;

 -- ALU performs ALUresult = bus_A + bus_B

 WHEN "010" => ResMux <= Ainput + Binput;

 -- ALU performs SLT

 WHEN "011" => ResMux <= Ainput - Binput;

 -- ALU performs ?

 WHEN "100" => ResMux <= To_stdlogicvector(B"00000000");

 -- ALU performs ?

 WHEN "101" => ResMux <= To_stdlogicvector(B"00000000");

 -- ALU performs ALUresult = bus_A -bus_B

 WHEN "110" => ResMux <= Ainput - Binput;

 -- ALU performs SLT

 WHEN "111" => ResMux <= To_stdlogicvector(B"00000000");

 WHEN Others => ResMux <= To_stdlogicvector(B"00000000");

 end case;

end process;

end behavior;

--


--


--  Idecode module (provides the register file for the SPIM computer)


--


-- Copyright (c) 1996 J. Hamblen, Georgia Tech, School of ECE, Atlanta, GA


--


library IEEE;


use IEEE.STD_LOGIC_1164.all;


use IEEE.STD_LOGIC_ARITH.all;

entity Idecode is

        port(rr1d_bus : out std_logic_vector(7 downto 0);

        rr2d_bus : out std_logic_vector(7 downto 0);

        Instruction : in std_logic_vector(31 downto 0);

        wrd_bus : in std_logic_vector(7 downto 0);

        RegWrite : in std_logic;

        RegDst : in std_logic;

        Extend : out std_logic_vector(7 downto 0);

                clock,reset: in std_logic);

end Idecode;

--

-- Idecode architecture

--

architecture behavior of Idecode is

signal wraddress : std_logic_vector(4 downto 0);

signal reg1,reg2,reg3,reg4: std_logic_vector(7 downto 0);

signal reg5,reg6,reg7: std_logic_vector(7 downto 0);

signal ireg1,ireg2,ireg3,ireg4: std_logic_vector(7 downto 0);

signal ireg5,ireg6,ireg7: std_logic_vector(7 downto 0);

signal mrr1d_bus,mrr2d_bus: std_logic_vector(7 downto 0);

signal muxreg1,muxreg2,muxreg3,muxreg4: std_logic_vector(7 downto 0);

signal muxreg5,muxreg6,muxreg7: std_logic_vector(7 downto 0);

signal reg1wr,reg2wr,reg3wr,reg4wr: std_logic;

signal reg5wr,reg6wr,reg7wr: std_logic;

signal rr1add_bus,rr2add_bus,wra_bus,wra2_bus: std_logic_vector(4 downto 0);

signal Ivalue: std_logic_vector(15 downto 0);

begin

   rr1add_bus <= Instruction(25 downto 21);

   rr2add_bus <= Instruction(20 downto 16);

   wra_bus <=  Instruction(15 downto 11);

   wra2_bus <=  Instruction(20 downto 16);

   Ivalue <= Instruction(15 downto 0);

-- Read Register Operations

                WITH rr1add_bus(2 downto 0) SELECT

                mrr1d_bus <= To_stdlogicvector(X"00")  WHEN "000", 



reg1 WHEN "001",



reg2 WHEN "010",



reg3 WHEN "011",

                reg4 WHEN "100",

                reg5 WHEN "101",

                reg6 WHEN "110",

                reg7 WHEN "111",

                To_stdlogicvector(X"FF") WHen others;

                WITH rr2add_bus(2 downto 0) SELECT

                mrr2d_bus <= To_stdlogicvector(X"00")  WHEN "000", 



reg1 WHEN "001",



reg2 WHEN "010",



reg3 WHEN "011",

                reg4 WHEN "100",

                reg5 WHEN "101",

                reg6 WHEN "110",

                reg7 WHEN "111",

                To_stdlogicvector(X"FF") WHen others;

    rr1d_bus <= mrr1d_bus;

    rr2d_bus <= mrr2d_bus;

-- Mux for Register Write Address

    wraddress <= wra_bus WHEN RegDst='1'     -- write address mux

                 ELSE wra2_bus;

-- Note: Initial values in registers set to register number during reset 

-- to provide simple test data for MIPS programs

 ireg1 <= To_stdlogicvector(X"01");

 ireg2 <= To_stdlogicvector(X"02");

 ireg3 <= To_stdlogicvector(X"03");

 ireg4 <= To_stdlogicvector(X"04");

 ireg5 <= To_stdlogicvector(X"05");

 ireg6 <= To_stdlogicvector(X"06");

 ireg7 <= To_stdlogicvector(X"07");

--  Use D FFs with enable (D input mux) to elminate hazards on clock line

--  muxregx is D input mux for register, regxwr is enable line for register

 muxreg1 <=reg1 WHEN reg1wr='0' ELSE wrd_bus;

 reg1wr <= '1' WHEN ((wraddress="00001") AND (RegWrite='1')) ELSE '0';

 muxreg2 <=reg2 WHEN reg2wr='0' ELSE wrd_bus;

 reg2wr <= '1' WHEN ((wraddress="00010") AND (RegWrite='1')) ELSE '0';

 muxreg3 <=reg3 WHEN reg3wr='0' ELSE wrd_bus;

 reg3wr <= '1' WHEN ((wraddress="00011") AND (RegWrite='1')) ELSE '0';

 muxreg4 <=reg4 WHEN reg4wr='0' ELSE wrd_bus;

 reg4wr <= '1' WHEN ((wraddress="00100") AND (RegWrite='1')) ELSE '0';

 muxreg5 <=reg5 WHEN reg5wr='0' ELSE wrd_bus;

 reg5wr <= '1' WHEN ((wraddress="00101") AND (RegWrite='1')) ELSE '0';

 muxreg6 <=reg6 WHEN reg6wr='0' ELSE wrd_bus;

 reg6wr <= '1' WHEN ((wraddress="00110") AND (RegWrite='1')) ELSE '0';

 muxreg7 <=reg7 WHEN reg7wr='0' ELSE wrd_bus;

 reg7wr <= '1' WHEN ((wraddress="00111") AND (RegWrite='1')) ELSE '0';

-- Sign Extend Unit  (NOTE: not needed for 8-bit only data path model)

--        Extend(15 downto 0) <= Ivalue;  -- Sign Extend 16 to 32 bits

--        Extend(31 downto 16) <= To_stdlogicvector(X"FFFF")

--        WHEN Ivalue(15)='1'ELSE To_stdlogicvector(X"0000");

                  Extend <= Ivalue(7 downto 0);

Process

 Begin

  wait until clock'event and clock='1';

  if reset='1' then

-- Initial register values on reset are reg=reg#

   reg1<=ireg1;

   reg2<=ireg2;

   reg3<=ireg3;

   reg4<=ireg4;

   reg5<=ireg5;

   reg6<=ireg6;

   reg7<=ireg7;

  else

-- Register loaded during write back?

   reg1<=muxreg1;

   reg2<=muxreg2;

   reg3<=muxreg3;

   reg4<=muxreg4;

   reg5<=muxreg5;

   reg6<=muxreg6;

   reg7<=muxreg7;

  end if;

 end process;

end behavior;

--


--


-- Ifetch module (provides the PC and instruction memory for the SPIM computer)

--

-- Copyright (c) 1996 J. Hamblen, Georgia Tech, School of ECE, Atlanta, GA

--

library IEEE;

use IEEE.STD_LOGIC_1164.all;

use IEEE.STD_LOGIC_ARITH.all;

use IEEE.STD_LOGIC_UNSIGNED.all;

entity Ifetch is

        port(signal Instruction : out std_logic_vector(31 downto 0);

        signal PCadd : out  std_logic_vector(7 downto 0);

        signal Addresult : in std_logic_vector(7 downto 0);

        signal Branch : in std_logic;

        signal clock, reset : in std_logic;

        signal Zero : in std_logic;

        signal PCout : out std_logic_vector(7 downto 0));

end Ifetch;

--

-- Ifetch architecture

--

architecture behavior of Ifetch is

          signal PC : std_logic_vector(7 downto 0);

          signal PCtemp : std_logic_vector(7 downto 0);

          signal PCaddtemp : std_logic_vector(8 downto 0);

-- Insert SPIM Machine Language Test Program Here

          constant mem0 : std_logic_vector(31 downto 0) := (

--          Field   | op | rs | rt | rd ?addr/immed|

To_Stdlogicvector(B"10001100000000100000000000000000")); -- lw $2,0

          constant mem1 : std_logic_vector(31 downto 0) := (

To_Stdlogicvector(B"10001100000000110000000000000001")); -- lw $3,1

          constant mem2 : std_logic_vector(31 downto 0) := (

To_Stdlogicvector(B"00000000010000110000100000100000")); -- add $1,$2,$3

          constant mem3 : std_logic_vector(31 downto 0) := (

To_Stdlogicvector(B"10101100000000010000000000000011")); -- sw $1,3

          constant mem4 : std_logic_vector(31 downto 0) := (

To_Stdlogicvector(B"00010000001000101111111111111111")); -- beq $1,$2,-4

          constant mem5 : std_logic_vector(31 downto 0) := (

To_Stdlogicvector(B"00010000001000011111111111111010")); -- beq $1,$1,-24

          constant mem6 : std_logic_vector(31 downto 0) := (

To_Stdlogicvector(B"00000000000000000000000000000000")); -- nop                                   

          constant mem7 : std_logic_vector(31 downto 0) := (

To_Stdlogicvector(B"00000000000000000000000000000000")); -- nop                                  


begin

-- Increment PC by 4        


PCout <= PC;

        PCaddtemp(7 downto 2) <= PC(7 downto 2) + CONV_STD_LOGIC_VECTOR(1,6);

        PCaddtemp(1 downto 0)<= CONV_STD_LOGIC_VECTOR(0,2);

        PCadd <= PCaddtemp(7 downto 0);

-- Mux for Branch Address or Next Address        


PCtemp <= Addresult WHEN ((Branch='1') AND (Zero='1')) 


ELSE PCaddtemp(7 downto 0);

-- Load next PC

        PROCESS

        Begin

        Wait Until (clock'event) and (clock='1');

          If reset='1' then

          PC<=To_Stdlogicvector(X"00"); else PC<=PCtemp;

          end if;

        end process;

-- Fetch Instruction from memory     

          Process (PC)

          begin

          case PC(4 downto 2) is          

           WHEN "000" => instruction <= mem0;

           WHEN "001" => instruction <= mem1;

           WHEN "010" => instruction <= mem2;

           WHEN "011" => instruction <= mem3;

           WHEN "100" => instruction <= mem4;

           WHEN "101" => instruction <= mem5;

           WHEN "110" => instruction <= mem6;

           when "111" => instruction <= mem7;

           when others => instruction <= To_stdlogicvector(X"00000000");

          end case;

          end process;

end behavior;

-- TOP_FLEX module


--


-- Flex - Mips Implementation


-- Uses VGA to Display Data 


-- PB1 is clock for Mips


-- PB2 is synchronous reset for Mips


-- i.e. must clock (hit PB1) while holding down PB2 for reset


-- PC is also displayed on 7 Segment Display

-- Flex Switch 3 is reverse video

--

--

-- VHDL synthesis and simulation model of MIPS single clock cycle machine

-- as described in chapter 5 of Patterson and Hennessey

-- VHDL Submodules Ifetch,Control,Idecode,Execute and Dmemory

-- become different pipeline stages in chapter 6.  The code 

-- for each of these VHDL modules in in *.VHD files

--

-- NOTE: Full 32-bit instructions are used. The Data paths were limited

-- to 8 bits to speed synthesis and simulation for student projects.

-- Registers are limited to 8 bits and $R0..$R7 only

-- Program memory limited to locations 0..7 and Data to locations 0..1

-- Register contain register address on reset.  Data memory

-- is initialized to 55 AA for program on reset

-- Use top_spim module to simulate MIPS without video display hardware

--

-- Jim Hamblen, Georgia Tech School of ECE

--

library IEEE;

use  IEEE.STD_LOGIC_1164.all;

use  IEEE.STD_LOGIC_ARITH.all;

use  IEEE.STD_LOGIC_UNSIGNED.all;

LIBRARY lpm;

USE lpm.lpm_components.ALL;

entity top_flex is

Generic(ADDR_WIDTH: integer := 12; DATA_WIDTH: integer := 1);

   port( signal PB1, PB2, Clock : in std_logic;

        signal LSB_a, LSB_b, LSB_c, LSB_d, LSB_e, LSB_f, LSB_g, LSB_dp,

        MSB_a, MSB_b, MSB_c, MSB_d, MSB_e, MSB_f, MSB_g, MSB_dp : out std_logic;               

        signal Red,Green,Blue : out std_logic;

        signal Horiz_sync,Vert_sync : out std_logic;

        signal MOUSE_DATA: in std_logic;

        signal MOUSE_CLK : in std_logic;

        signal Flex_Switch_1, Flex_Switch_2, Flex_Switch_3, Flex_Switch_4: in std_logic;

        signal Flex_Switch_5, Flex_Switch_6, Flex_Switch_7, Flex_Switch_8: in std_logic);

end top_flex;

architecture behavior of top_flex is

   component Ifetch

   port(Instruction: out std_logic_vector(31 downto 0);

        PCadd : out  std_logic_vector(7 downto 0);

        Addresult : in std_logic_vector(7 downto 0);

        Branch : in std_logic;

        clock,reset : in std_logic;

        Zero : in std_logic;

        PCout : out std_logic_vector(7 downto 0));

   end component;

   component Idecode

   port(rr1d_bus : out std_logic_vector(7 downto 0);

        rr2d_bus : out std_logic_vector(7 downto 0);

        Instruction : in std_logic_vector(31 downto 0);

        wrd_bus : in std_logic_vector(7 downto 0);

        RegWrite : in std_logic;

        RegDst : in std_logic;

        Extend : out std_logic_vector(7 downto 0);

        clock,reset: in std_logic);


end component;

   component control

   port( Op : in std_logic_vector(5 downto 0);

                RegDst : out std_logic;

                ALUSrc : out std_logic;

                MemtoReg : out std_logic;

                RegWrite : out std_logic;

                MemRead : out std_logic;

                MemWrite : out std_logic;

                Branch : out std_logic;

                ALUop0 : out std_logic;

                ALUop1 : out std_logic;

                clock: in std_logic);


 end component;

   component  Execute

   port(Readdata1 : in std_logic_vector(7 downto 0);

                Readdata2 : in std_logic_vector(7 downto 0);

                Extend : in std_logic_vector(7 downto 0);

                Func_op : in std_logic_vector(5 downto 0);

                ALUOp0 : in std_logic;

                ALUOp1 : in std_logic; 

                ALUSrc : in std_logic;

                Zero : out std_logic;

                ALUResult : out std_logic_vector(7 downto 0);

                ADDResult : out std_logic_vector(7 downto 0);

                PCadd : in std_logic_vector(7 downto 0);

                clock: in std_logic);


end component;

   component dmemory

   port(rd_bus : out std_logic_vector(7 downto 0);

        ra_bus : in std_logic_vector(7 downto 0);

        wd_bus : in std_logic_vector(7 downto 0);

        wadd_bus : in std_logic_vector(7 downto 0);

        MemRead, Memwrite, MemtoReg : in std_logic;

        clock,reset: in std_logic);

   end component;

   signal PCadd, PC :  std_logic_vector(7 downto 0);

   signal rr1d_bus : std_logic_vector(7 downto 0);

   signal rr2d_bus : std_logic_vector(7 downto 0);

   signal Extend : std_logic_vector(7 downto 0);

   signal Addresult : std_logic_vector(7 downto 0);

   signal ALUresult : std_logic_vector(7 downto 0);

   signal Branch : std_logic;

   signal Zero : std_logic;

   signal wrd_bus : std_logic_vector(7 downto 0);

   signal RegWrite : std_logic;

   signal RegDst :  std_logic;

   signal ALUSrc :  std_logic;

   signal MemtoReg :  std_logic;

   signal MemRead :  std_logic;

   signal MemWrite :  std_logic;

   signal ALUop :  std_logic_vector(1 downto 0);

   signal MIPS_Inst: std_logic_vector(31 downto 0);

   signal MIPS_Clock, Reset: std_logic;

-- Video Display Signals

signal H_count,V_count: std_logic_vector(9 Downto 0);

signal F_count: std_logic_vector(4 Downto 0);

signal Color_count: std_logic_vector(3 Downto 0);

signal Red_Data, Green_Data, Blue_Data, Power_On, Rev_video : std_logic;

-- Signals for Video ROM Memory for Pixel Data

signal rom_address: std_logic_vector(8 Downto 0);

signal sum_address: std_logic_vector(6 Downto 0);

signal rom_data: std_logic_vector(7 Downto 0);

signal col_address, row_address: std_logic_vector(5 Downto 0);

signal pixel_col_count, pixel_row_count: std_logic_vector(5 Downto 0);

signal rom_mux_output: std_logic;

signal format_address: std_logic_vector(5 downto 0);

signal format_data: std_logic_vector(5 downto 0);

-- Signals for LED Display

signal LSB,MSB: std_logic_vector(3 Downto 0);

signal LSB_7SEG,MSB_7SEG: std_logic_vector(6 Downto 0);

-- Signals for Push buttons

signal PB1_sync, PB2_sync, PB2_Single_Pulse, PB1_Single_Pulse: std_logic; 

signal PB2_debounced, PB1_debounced, PB2_debounced_Sync, PB1_debounced_Sync: std_logic; 

signal PB1_debounced_delay, PB2_debounced_delay, Debounce_clock: std_logic;

signal SHIFT_PB1, SHIFT_PB2: std_logic_vector(3 Downto 0);

signal switch, switch_sync: std_logic_vector(7 Downto 0);

constant H_max : std_logic_vector(9 Downto 0) := CONV_STD_LOGIC_VECTOR(799,10); 

-- 799 is max horiz count

constant V_max : std_logic_vector(9 Downto 0) := CONV_STD_LOGIC_VECTOR(524,10); 

-- 524 is max vert count

signal video_on, video_on_H, video_on_V: std_logic;

begin

-- Small 8 by 8 Character Genrator ROM for Video Display

 tiny_char_gen_rom: lpm_rom

      GENERIC MAP ( lpm_widthad => 9,

        lpm_numwords => "512",

        lpm_outdata => "UNREGISTERED",

        lpm_address_control => "UNREGISTERED",

-- Reads in mif file for character generator data 

         lpm_file => "tcgrom.mif",

         lpm_width => 8)

      PORT MAP ( address => rom_address, q => rom_data);

-- Character Format ROM for Video Display

-- Displays constant format character data

-- on left side of Display area

 format_rom: lpm_rom

      GENERIC MAP ( lpm_widthad => 6,

        lpm_numwords => "60",

        lpm_outdata => "UNREGISTERED",

        lpm_address_control => "UNREGISTERED",

-- Reads in mif file for data display format

         lpm_file => "format.mif",

         lpm_width => 6)

      PORT MAP ( address => format_address, q => format_data);

---------------------------------------------------------------------------------------

-- MIPS structural model - contains processor module interconnections

-- Code for each module is in *.VHD files

--

   IFE : Ifetch

   port map (Instruction => MIPS_Inst,

        PCadd => PCadd,


    Addresult => Addresult,


    Branch => Branch,

        clock => mips_clock,  reset => reset,


    Zero => Zero,


    PCout => PC);

   ID : Idecode

   port map (rr1d_bus => rr1d_bus,

        rr2d_bus => rr2d_bus,

        Instruction => MIPS_Inst,

        wrd_bus => wrd_bus,


    RegWrite => RegWrite,


    RegDst => RegDst,


    Extend => Extend,

        clock => mips_clock,  reset => reset);

   CTL:   control

   port map ( Op => MIPS_Inst(31 downto 26),



RegDst => RegDst,



ALUSrc => ALUSrc,



MemtoReg => MemtoReg,



RegWrite => RegWrite,



MemRead => MemRead,



MemWrite => MemWrite,



Branch => Branch,



ALUop0 => ALUop(0),



ALUop1 => ALUop(1),

                clock => mips_clock);

   EXE:  Execute

   port map (Readdata1 => rr1d_bus,

             Readdata2 => rr2d_bus,



     Extend => Extend,

             Func_op => MIPS_Inst(5 downto 0),



     ALUOp0 => ALUop(0),



     ALUOp1 => ALUop(1), 



     ALUSrc => ALUSrc,



     Zero => Zero,

             ALUResult => ALUResult,



     ADDResult => ADDResult,



     PCadd => PCadd,

             clock => mips_clock);

   MEM:  dmemory

   port map (rd_bus => wrd_bus,


         ra_bus => ALUResult,


         wd_bus => rr2d_bus,

             wadd_bus => ALUResult,


         MemRead => MemRead, 


         Memwrite => MemWrite, 


         MemtoReg => MemtoReg,

             clock => mips_clock,  reset => reset);

------------------------------------------------------------------------------

-- Reset and Clock Signal for MIPS processor

Reset <=  PB2_Debounced_Sync;

Mips_clock <= PB1_Debounced_Sync;

-- Colors for pixel data on video signal

-- address video_rom for pixel color data

-- Switch 2 or Rev_Video will reverse video

Red_Data <= not ((rom_mux_output xor Switch_Sync(2)) xor Rev_video);

Green_Data <= not ((rom_mux_output xor Switch_Sync(2)) xor Rev_video);

Blue_Data <= '1';

-- Display 8 by 8 font with 16 by 16 pixel array

-- Step through rows for each character pattern

rom_address(2 Downto 0) <= pixel_row_count(3 Downto 1);

-- Mux to pick off correct rom data bit from 8-bit word

-- for on screen character generation

rom_mux_output <= rom_data ( (CONV_INTEGER(NOT pixel_col_count(3 downto 1))));

-- The RGB signal pins to the VGA monitor

Red <=   Red_Data and video_on;

Green <= Green_Data and video_on;

Blue <=  Blue_Data and video_on;

-- video_on turns off pixel data when not in the view area

video_on <= video_on_H and video_on_V;

-- Combine Flex Dip Switch Inputs into Switch vector

Switch <= Flex_Switch_8 & Flex_Switch_7 & Flex_Switch_6 & Flex_Switch_5 &

          Flex_Switch_4 & Flex_Switch_3 & Flex_Switch_2 & Flex_Switch_1;

-- This process generates the signals needed for a Video Display

--It Generates Horizontal and Vertical Timing Signals for Video the Signal

--It also counts pixel rows and columns to provide addresses for the

--process that generates the data for the Video Signal

VIDEO_DISPLAY: Process

Begin

Wait until(Clock'Event) and (Clock='1');

If Power_on = '0' Then

 H_count <= CONV_STD_LOGIC_VECTOR(654,10);

 V_count <= CONV_STD_LOGIC_VECTOR(493,10);

 Video_on_H <= '0';

 Video_on_V <= '0';

 Power_On <= '1';

Else

-- H_count counts pixels (640 + extra time for sync signals)

--

--   <-Clock out RGB Pixel Row Data ->   <-H Sync->

--   ------------------------------------__________--------

--   0                           640   659       755    799

--

If (H_count >= H_max) then

   H_count <= To_Stdlogicvector(B"0000000000");

Else

   H_count <= H_count + To_Stdlogicvector(B"0000000001");

End if;

--Generate Horizontal Sync Signal

If (H_count <= CONV_STD_LOGIC_VECTOR(755,10)) and (H_count >= CONV_STD_LOGIC_VECTOR(659,10)) Then

   Horiz_Sync <= '0';

ELSE

   Horiz_Sync <= '1';

End if;

--V_count counts rows of pixels (480 + extra time for sync signals)

--

--  <---- 480 Horizontal Syncs (pixel rows) -->  ->V Sync<-

--  -----------------------------------------------_______------------

--  0                                       480    493-494          524

--

If (V_count >= V_max) and (H_count >= CONV_STD_LOGIC_VECTOR(699,10)) then

   V_count <= To_Stdlogicvector(B"0000000000");

Else If (H_count = CONV_STD_LOGIC_VECTOR(699,10)) Then

   V_count <= V_count + To_Stdlogicvector(B"0000000001");

End if;

End if;

-- Generate Vertical Sync Signal

If (V_count <= CONV_STD_LOGIC_VECTOR(494,10)) and (V_count >= CONV_STD_LOGIC_VECTOR(493,10)) Then

   Vert_Sync <= '0';

   Debounce_CLock <= '0';

ELSE

   Vert_Sync <= '1';

   Debounce_Clock <= '1';

End if;

-- Generate Video on Screen Signals for Pixel Data

-- Generate row and col address for 16 by 16 font

--

If (H_count <= CONV_STD_LOGIC_VECTOR(639,10)) Then

   video_on_H <= '1';

If pixel_col_count < CONV_STD_LOGIC_VECTOR(15,6) Then

   pixel_col_count <= pixel_col_count + '1';

Else

   pixel_col_count <= "000000";

   col_address <= col_address + '1';

End if;

ELSE

   video_on_H <= '0';

   pixel_col_count <= "000000";

   col_address <= "000000";

End if;

IF(H_COUNT = CONV_STD_LOGIC_VECTOR(641,10)) Then

    pixel_row_count <= pixel_row_count + '1';

If (pixel_row_count = CONV_STD_LOGIC_VECTOR(15,6)) THEN

   pixel_row_count <= "000000";

   row_address <= row_address + '1';

End if;

End if;

If (V_count <= CONV_STD_LOGIC_VECTOR(479,10)) Then

   video_on_V <= '1';

ELSE

   video_on_V <= '0';

   pixel_row_count <= "000000";

   row_address <= "000000";

End if;

If (V_count = CONV_STD_LOGIC_VECTOR(0,10)) and (H_count = CONV_STD_LOGIC_VECTOR(0,10)) then

If (F_count = CONV_STD_LOGIC_VECTOR(30,5)) then

   F_count <= To_Stdlogicvector(B"00000");

Else 

   F_count <= F_count + To_Stdlogicvector(B"00001");

End if;

End if;

End if;

end process VIDEO_DISPLAY;

-- Address for Constant Character Data ROM

format_address(1 Downto 0) <= Col_address(1 Downto 0);

format_address(5 Downto 2) <= Row_address(4 Downto 1);

-- This Process Provides Character Data for Video Display

-- by generating addresses for the Character Generator ROM

-- using row address and col address provided by the Video 

-- Display process 

VIDEO_DISPLAY_DATA: process

begin

  wait until (clock'event) and (clock='1');

-- Reverse Video for Title at top of screen

If (row_address <= "00011") Then rev_video <= '1'; 

ELSE rev_video <= '0';

End if;

If (row_address(0)='0')  or

   (col_address < "001000") or (col_address >"010101") 

-- Blank characters on Edges and alternating lines

Then rom_address(8 Downto 3) <= "100000";

Else 

If ((col_address >= "001000") and (col_address <= "001011")) Then

-- Constant Character Area from ROM

 rom_address(8 Downto 3) <= format_data;

 Else

-- Couple of Spaces

 If (col_address = "001100") or (col_address = "001101") 

-- Blank on Top and Bottom line of Display Area  

 or (row_address < "00010") or (row_address > "11011")

 Then rom_address(8 Downto 3) <= "100000";

Else

-- Numeric Data From Simulation

-- Display Values in Hex

  CASE  row_address(4 Downto 1) IS


WHEN  "0001"  =>

-- Print "Computer" on first line of data display area

 
    If col_address = "001110" 

         Then rom_address(8 Downto 3) <= "000011";

        End if;


    If col_address = "001111" 

         Then rom_address(8 Downto 3) <= "001111" ;

        End if;


    If col_address = "010000" 

         Then rom_address(8 Downto 3) <= "001101" ;

        End if;


    If col_address = "010001" 

         Then rom_address(8 Downto 3) <= "010000" ;

        End if;


    If col_address = "010010" 

         Then rom_address(8 Downto 3) <= "010101" ;

        End if;


    If col_address = "010011" 

         Then rom_address(8 Downto 3) <= "010100" ;

        End if;


    If col_address = "010100" 

         Then rom_address(8 Downto 3) <= "000101" ;

        End if;


    If col_address = "010101" 

         Then rom_address(8 Downto 3) <= "010010" ;

        End if;


WHEN  "0010" =>


    If col_address = "010100" 

 -- Selects Hex Character Address with 4-bit value from signal

        Then rom_address(8 Downto 3) <= "11" & PC(7 Downto 4);

        Else If col_address = "010101" 

  -- Selects Hex Character Address with 4-bit value from signal

        Then rom_address(8 Downto 3) <= "11" & PC(3 Downto 0);

        Else

         rom_address(8 Downto 3) <= "110000";

        End if;

        End if;


WHEN  "0011"  =>


    If col_address = "001110" 

 -- Selects Hex Character Address with 4-bit value from signal

         Then rom_address(8 Downto 3) <= "11" & MIPS_Inst(31 Downto 28);

        End if;


    If col_address = "001111" 

         Then rom_address(8 Downto 3) <= "11" & MIPS_Inst(27 Downto 24);

        End if;


    If col_address = "010000" 

         Then rom_address(8 Downto 3) <= "11" & MIPS_Inst(23 Downto 20);

        End if;


    If col_address = "010001" 

         Then rom_address(8 Downto 3) <= "11" & MIPS_Inst(19 Downto 16);

        End if;


    If col_address = "010010" 

         Then rom_address(8 Downto 3) <= "11" & MIPS_Inst(15 Downto 12);

        End if;


    If col_address = "010011" 

         Then rom_address(8 Downto 3) <= "11" & MIPS_Inst(11 Downto 8);

        End if;


    If col_address = "010100" 

         Then rom_address(8 Downto 3) <= "11" & MIPS_Inst(7 Downto 4);

        End if;


    If col_address = "010101" 

         Then rom_address(8 Downto 3) <= "11" & MIPS_Inst(3 Downto 0);

        End if;


WHEN   "0100"  =>


    If col_address = "010100" 

  -- Selects Hex Character Address with 4-bit value from signal

        Then rom_address(8 Downto 3) <= "11" & rr1d_bus(7 Downto 4);

        Else If col_address = "010101" 

         Then rom_address(8 Downto 3) <= "11" & rr1d_bus(3 Downto 0);

        Else

         rom_address(8 Downto 3) <= "110000";

        End if;

        End if;


WHEN   "0101"  =>


    If col_address = "010100" 

  -- Selects Hex Character Address with 4-bit value from signal

        Then rom_address(8 Downto 3) <= "11" & rr2d_bus(7 Downto 4);

        Else If col_address = "010101" 

         Then rom_address(8 Downto 3) <= "11" & rr2d_bus(3 Downto 0);

        Else

         rom_address(8 Downto 3) <= "110000";

        End if;

        End if;


WHEN   "0110"  =>


    If col_address = "010100" 

 -- Selects Hex Character Address with 4-bit value from signal

        Then rom_address(8 Downto 3) <= "11" & ALUresult(7 Downto 4);

        Else If col_address = "010101" 

         Then rom_address(8 Downto 3) <= "11" & ALUresult(3 Downto 0);

        Else

         rom_address(8 Downto 3) <= "110000";

        End if;

        End if;


WHEN   "0111"  =>


    If col_address = "010100" 

  -- Selects Hex Character Address with 4-bit value from signal

        Then rom_address(8 Downto 3) <= "11" & wrd_bus(7 Downto 4);

        Else If col_address = "010101" 

         Then rom_address(8 Downto 3) <= "11" & wrd_bus(3 Downto 0);

        Else

         rom_address(8 Downto 3) <= "110000";

        End if;

        End if;


WHEN   "1000"  =>


    If col_address = "001110" 

-- Select "0" or "1" character address

        Then rom_address(8 Downto 3) <= "11000" & Branch;

        Else

         rom_address(8 Downto 3) <= "100000";

        End if;


WHEN   "1001"  =>


    If col_address = "001110" 

-- Select "0" or "1" character address

         Then rom_address(8 Downto 3) <= "11000" & Zero;

        Else

         rom_address(8 Downto 3) <= "100000";

        End if;


WHEN   "1010"  =>


    If col_address = "001110" 

 -- Select "0" or "1" character address

        Then rom_address(8 Downto 3) <= "11000" & Memread;

        Else

         rom_address(8 Downto 3) <= "100000";

        End if;


WHEN   "1011"  =>


    If col_address = "001110" 

 -- Select "0" or "1" character address

        Then rom_address(8 Downto 3) <= "11000" & Memwrite;

        Else

         rom_address(8 Downto 3) <= "100000";

        End if;


WHEN   "1100"  =>


    If col_address = "001110" 

 -- Select Up arrow or Down arrow character address

        Then rom_address(8 Downto 3) <= "0111" & MIPS_Clock & "0";

        Else

         rom_address(8 Downto 3) <= "100000";

        End if;


WHEN   "1101"  =>


    If col_address = "001110" 

 -- Select Up arrow or Down arrow character address

         Then rom_address(8 Downto 3) <= "0111" & Reset & "0";

        Else

         rom_address(8 Downto 3) <= "100000";

        End if;


WHEN OTHERS =>

      rom_address(8 Downto 3) <= "100000";

  END CASE;

  end if;

 end if;

end if;

end process VIDEO_DISPLAY_DATA;

-- Values to Display in 7Seg LEDs

MSB_dp <= NOT MIPS_CLOCK;

LSB_dp <= NOT RESET;

MSB <= PC (7 Downto 4);

LSB <= PC (3 Downto 0);

MSB_a <= NOT MSB_7SEG(6);

MSB_b <= NOT MSB_7SEG(5);

MSB_c <= NOT MSB_7SEG(4);

MSB_d <= NOT MSB_7SEG(3);

MSB_e <= NOT MSB_7SEG(2);

MSB_f <= NOT MSB_7SEG(1);

MSB_g <= NOT MSB_7SEG(0);

LSB_a <= NOT LSB_7SEG(6);

LSB_b <= NOT LSB_7SEG(5);

LSB_c <= NOT LSB_7SEG(4);

LSB_d <= NOT LSB_7SEG(3);

LSB_e <= NOT LSB_7SEG(2);

LSB_f <= NOT LSB_7SEG(1);

LSB_g <= NOT LSB_7SEG(0);

LED_DISPLAY: process  (MSB,LSB)

-- BCD to 7 Segment Decoders for LED Displays

begin

CASE MSB IS

        WHEN "0000" =>

            MSB_7SEG <= "1111110";

        WHEN "0001" =>

            MSB_7SEG <= To_StdLogicVector(B"0110000");

        WHEN "0010" =>

            MSB_7SEG <= To_StdLogicVector(B"1101101");

        WHEN "0011" =>

            MSB_7SEG <= To_StdLogicVector(B"1111001");

        WHEN "0100" =>

            MSB_7SEG <= To_StdLogicVector(B"0110011");

        WHEN "0101" =>

            MSB_7SEG <= To_StdLogicVector(B"1011011");

        WHEN "0110" =>

            MSB_7SEG <= To_StdLogicVector(B"1011111");

        WHEN "0111" =>

            MSB_7SEG <= To_StdLogicVector(B"1110000");

        WHEN "1000" =>

            MSB_7SEG <= To_StdLogicVector(B"1111111");

        WHEN "1001" =>

            MSB_7SEG <= To_StdLogicVector(B"1111011"); 

        WHEN "1010" =>

            MSB_7SEG <= To_StdLogicVector(B"1110111");

        WHEN "1011" =>

            MSB_7SEG <= To_StdLogicVector(B"0011111");

        WHEN "1100" =>

            MSB_7SEG <= To_StdLogicVector(B"1001110");

        WHEN "1101" =>

            MSB_7SEG <= To_StdLogicVector(B"0111101"); 

        WHEN "1110" =>

            MSB_7SEG <= To_StdLogicVector(B"1001111");

        WHEN "1111" =>

            MSB_7SEG <= To_StdLogicVector(B"1000111");


WHEN OTHERS =>

            MSB_7SEG <= To_StdLogicVector(B"0000001");

END CASE;

CASE LSB IS

        WHEN "0000" =>

            LSB_7SEG <= To_StdLogicVector(B"1111110");

        WHEN "0001" =>

            LSB_7SEG <= To_StdLogicVector(B"0110000");

        WHEN "0010" =>

            LSB_7SEG <= To_StdLogicVector(B"1101101");

        WHEN "0011" =>

            LSB_7SEG <= To_StdLogicVector(B"1111001");

        WHEN "0100" =>

            LSB_7SEG <= To_StdLogicVector(B"0110011");

        WHEN "0101" =>

            LSB_7SEG <= To_StdLogicVector(B"1011011");

        WHEN "0110" =>

            LSB_7SEG <= To_StdLogicVector(B"1011111");

        WHEN "0111" =>

            LSB_7SEG <= To_StdLogicVector(B"1110000");

        WHEN "1000" =>

            LSB_7SEG <= To_StdLogicVector(B"1111111");

        WHEN "1001" =>

            LSB_7SEG <= To_StdLogicVector(B"1111011"); 

        WHEN "1010" =>

            LSB_7SEG <= To_StdLogicVector(B"1110111");

        WHEN "1011" =>

            LSB_7SEG <= To_StdLogicVector(B"0011111");

        WHEN "1100" =>

            LSB_7SEG <= To_StdLogicVector(B"1001110");

        WHEN "1101" =>

            LSB_7SEG <= To_StdLogicVector(B"0111101"); 

        WHEN "1110" =>

            LSB_7SEG <= To_StdLogicVector(B"1001111");

        WHEN "1111" =>

            LSB_7SEG <= To_StdLogicVector(B"1000111");


WHEN OTHERS =>

            LSB_7SEG <= To_StdLogicVector(B"0000001");

END CASE;

end process LED_DISPLAY;

-- Sync extenal pushbutton inputs to chip clock

PUSH_BUTTON: process (clock)

begin

  wait until (clock'event) and (clock='1');

PB1_Sync <= NOT PB1;

PB2_Sync <= NOT PB2;

Switch_Sync <= Switch;

PB1_DEBOUNCED_SYNC <= PB1_DEBOUNCED;

PB2_DEBOUNCED_SYNC <= PB2_DEBOUNCED;

end process PUSH_BUTTON;

-- Debounce Button: Filters out mechanical bounce for around 80Ms.

-- Debounce clock uses Vert_Sync timing signal (16Ms) to save hardware

-- for clock prescaler

DEBOUNCE_BUTTON1: process (debounce_clock)

begin

  wait until (debounce_clock'event) and (debounce_clock='1');

  SHIFT_PB1(2 Downto 0) <= SHIFT_PB1(3 Downto 1);

  SHIFT_PB1(3) <= PB1_Sync;

  If SHIFT_PB1(3 Downto 0)="1111" THEN

    PB1_DEBOUNCED <= '1';

  ELSE 

    PB1_DEBOUNCED <= '0';

  End if;

end process DEBOUNCE_BUTTON1;

DEBOUNCE_BUTTON2: process (debounce_clock)

begin

  wait until (debounce_clock'event) and (debounce_clock='1');

  SHIFT_PB2(2 Downto 0) <= SHIFT_PB2(3 Downto 1);

  SHIFT_PB2(3) <= PB2_Sync;

  If SHIFT_PB2(3 Downto 0)="1111" THEN

    PB2_DEBOUNCED <= '1';

  ELSE 

    PB2_DEBOUNCED <= '0';

  End if;

end process DEBOUNCE_BUTTON2;

SINGLE_PULSE_PB1: process (Clock)

begin

  wait until (CLOCK'event) and (CLOCK='1');

  If POWER_ON='0' Then

  PB1_SINGLE_PULSE <='0';

  PB1_DEBOUNCED_DELAY <= '1';

  ELSE

-- Generates Single Clock Cycle Pulse When Switch Hit

-- No matter how long switch is held down

  IF PB1_DEBOUNCED_SYNC = '1' AND PB1_DEBOUNCED_DELAY = '0' THEN

   PB1_SINGLE_PULSE <= '1';

  ELSE

   PB1_SINGLE_PULSE <= '0';

  END IF;

  PB1_DEBOUNCED_DELAY <= PB1_DEBOUNCED_SYNC;

 End if;

end process SINGLE_PULSE_PB1;

SINGLE_PULSE_PB2: process (Clock)

begin

  wait until (CLOCK'event) and (CLOCK='1');

   If POWER_ON='0' Then

    PB2_SINGLE_PULSE <='0';

    PB2_DEBOUNCED_DELAY <= '1';

   ELSE

    PB2_DEBOUNCED_DELAY <= PB2_DEBOUNCED_SYNC;

-- Generates Single Clock Cycle Pulse When Switch Hit

-- No matter how long switch is held down

    IF PB2_DEBOUNCED_SYNC = '1' AND PB2_DEBOUNCED_DELAY = '0' THEN

     PB2_SINGLE_PULSE <= '1';

    ELSE

     PB2_SINGLE_PULSE <= '0';

    END IF;

  End if;

end process SINGLE_PULSE_PB2;

end behavior;

--


--

-- TOP_SPIM module

--

-- VHDL synthesis and simulation model of MIPS single clock cycle machine

-- as described in chapter 5 of Patterson and Hennessey

-- VHDL Submodules Ifetch,Control,Idecode,Execute and Dmemory

-- become different pipeline stages in chapter 6

--

-- NOTE: Full 32-bit instructions are used. The Data paths were limited

-- to 8 bits to speed synthesis and simulation for student projects.

-- Registers are limited to 8 bits and $R0..$R7 only

-- Program memory limited to locations 0..7 and Data to locations 0..1

--

-- Copyright (c) 1996 J. Hamblen, Georgia Tech, School of ECE, Atlanta, GA

-- Educational Use Rights Granted Provided Copyright Remains in Source Code

--

library IEEE;

use IEEE.STD_LOGIC_1164.all;

use IEEE.STD_LOGIC_ARITH.all;

entity TOP_SPIM is

port(reset,clock: in std_logic; PC,ALUresult,rr1d_bus,rr2d_bus,

     wrd_bus: out std_logic_vector(7 downto 0);

     Out_Inst: out std_logic_vector(31 downto 0));

end TOP_SPIM;

architecture structure of TOP_SPIM is

   component Ifetch

   port(Instruction: out std_logic_vector(31 downto 0);

        PCadd : out  std_logic_vector(7 downto 0);

        Addresult : in std_logic_vector(7 downto 0);

        Branch : in std_logic;

        clock,reset : in std_logic;

        Zero : in std_logic;

        PCout : out std_logic_vector(7 downto 0));

   end component;

   component Idecode

   port(rr1d_bus : out std_logic_vector(7 downto 0);

        rr2d_bus : out std_logic_vector(7 downto 0);

        Instruction : in std_logic_vector(31 downto 0);

        wrd_bus : in std_logic_vector(7 downto 0);

        RegWrite : in std_logic;

        RegDst : in std_logic;

        Extend : out std_logic_vector(7 downto 0);

        clock,reset: in std_logic);


end component;

   component control

   port( Op : in std_logic_vector(5 downto 0);

                RegDst : out std_logic;

                ALUSrc : out std_logic;

                MemtoReg : out std_logic;

                RegWrite : out std_logic;

                MemRead : out std_logic;

                MemWrite : out std_logic;

                Branch : out std_logic;

                ALUop0 : out std_logic;

                ALUop1 : out std_logic;

                clock: in std_logic);


 end component;

   component  Execute

   port(Readdata1 : in std_logic_vector(7 downto 0);

                Readdata2 : in std_logic_vector(7 downto 0);

                Extend : in std_logic_vector(7 downto 0);

                Func_op : in std_logic_vector(5 downto 0);

                ALUOp0 : in std_logic;

                ALUOp1 : in std_logic; 

                ALUSrc : in std_logic;

                Zero : out std_logic;

                ALUResult : out std_logic_vector(7 downto 0);

                ADDResult : out std_logic_vector(7 downto 0);

                PCadd : in std_logic_vector(7 downto 0);

                clock: in std_logic);


end component;

   component dmemory

   port(rd_bus : out std_logic_vector(7 downto 0);

        ra_bus : in std_logic_vector(7 downto 0);

        wd_bus : in std_logic_vector(7 downto 0);

        wadd_bus : in std_logic_vector(7 downto 0);

        MemRead, Memwrite, MemtoReg : in std_logic;

        clock,reset: in std_logic);

   end component;

   signal PCadd :  std_logic_vector(7 downto 0);

   signal rr1d_busl : std_logic_vector(7 downto 0);

   signal rr2d_busl : std_logic_vector(7 downto 0);

   signal Extend : std_logic_vector(7 downto 0);

   signal Addresult : std_logic_vector(7 downto 0);

   signal ALUresultl : std_logic_vector(7 downto 0);

   signal Branch : std_logic;

   signal Zero : std_logic;

   signal wrd_busl : std_logic_vector(7 downto 0);

   signal RegWrite : std_logic;

   signal RegDst :  std_logic;

   signal ALUSrc :  std_logic;

   signal MemtoReg :  std_logic;

   signal MemRead :  std_logic;

   signal MemWrite :  std_logic;

   signal ALUop :  std_logic_vector(1 downto 0);

   signal MIPS_Inst: std_logic_vector(31 downto 0);

begin

   Out_Inst <= MIPS_Inst;

   ALUresult <= ALUresultl;

   rr1d_bus <= rr1d_busl;

   rr2d_bus <= rr2d_busl;

   wrd_bus  <= wrd_busl;

   IFE : Ifetch

   port map (Instruction => MIPS_Inst,

        PCadd => PCadd,


Addresult => Addresult,


Branch => Branch,

        clock => clock,  reset => reset,


Zero => Zero,


PCout => PC);

   ID : Idecode

   port map (rr1d_bus => rr1d_busl,

        rr2d_bus => rr2d_busl,

        Instruction => MIPS_Inst,

        wrd_bus => wrd_busl,


RegWrite => RegWrite,


RegDst => RegDst,


Extend => Extend,

        clock => clock,  reset => reset);

   CTL:   control

   port map ( Op => MIPS_Inst(31 downto 26),



RegDst => RegDst,



ALUSrc => ALUSrc,



MemtoReg => MemtoReg,



RegWrite => RegWrite,



MemRead => MemRead,



MemWrite => MemWrite,



Branch => Branch,



ALUop0 => ALUop(0),



ALUop1 => ALUop(1),

                clock => clock);

   EXE:  Execute

   port map (Readdata1 => rr1d_busl,

                Readdata2 => rr2d_busl,



Extend => Extend,

                Func_op => MIPS_Inst(5 downto 0),



ALUOp0 => ALUop(0),



ALUOp1 => ALUop(1), 



ALUSrc => ALUSrc,



Zero => Zero,

                ALUResult => ALUResultl,



ADDResult => ADDResult,



PCadd => PCadd,

                clock => clock);

   MEM:  dmemory

   port map (rd_bus => wrd_busl,


ra_bus => ALUResultl,


wd_bus => rr2d_busl,

        wadd_bus => ALUResultl,


MemRead => MemRead, 


Memwrite => MemWrite, 


MemtoReg => MemtoReg,

                clock => clock,  reset => reset);

end structure;
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